RP9 crashes when adding Large list into DropDown box

Hi … when I tried to paste a list of nearly 1000 rows into the Dropdown list widget … the application crashed.
I know 1000 is a lot … but the app should not crash…

Great product.

Hi!

Hmm, are you still able to reproduce this now? I’ve done a quick test on our end in a new file by pasting a selection of 1369 rows of text into the droplist field’s “Edit Many” dialog, and while I did see a delay I didn’t get a hard crash. If you’re still able to reproduce the crash, can you let us know where you’re copying the text from? Is it from a spreadsheet like Excel or Google Sheets (which is what I used to test)? Also, are you seeing this on Windows or a Mac?

Hi … I did it from a spreadsheet … but I just tried the same list straight from Notepad and it still crashed.

Hmmm, it sounds like you’re consistently able to reproduce the crash. I’ve tried to reproduce the crash on both Windows and Mac, and while I do get the app freezing for a moment it doesn’t crash. If you’re able to attach the crash log that you get from the OS along with any Axure RP logs generated today in an email to support@axure.com then we can gather those together and file a report for further investigation.

On Windows, Axure RP logs can be found below:

C:\Users%USERNAME%\AppData\Local\Axure\logs

On a Mac, they’re here:

~/Library/Application Support/Axure/Axure-9-0/logs

For Windows crash logs:

  1. Open the Start menu and search for “Event Viewer”.

  2. Open the Event Viewer application, and then navigate to “Event Viewer (Local) > Windows Logs > Application” in the left-hand sidebar.

  3. Once you’re there, select “Action > Find” and search for “AxureRP9.exe”. Look for any “Error” level entries; when you find one, please save the error log and attach it to this email. If you see any “.NET Runtime” errors that occurred immediately before or after the Axure RP error, please send those error logs as well.

On a Mac, you can get your crash logs by searching “Console” in the spotlight search, opening the Console dialog, and looking for Axure RP logs in the “User Reports” section of the left-hand sidebar. If you find any, please save them and attach the files to your email.

We’ll keep an eye out! Thank you!

Hi all, adamhughes wrote in with the error log to our help desk and we’ve gone ahead and filed a bug report for this issue. We’ll investigate on our end and will post if there are updates. In the meantime, you can keep an eye out for the release notes for a list of bug fixes either via “Help > Check for Updates” or on the release note forum thread. Thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.